<?xml version="1.0" encoding="ISO-8859-1"?>
<!-- Licensed to the Apache Software Foundation (ASF) under one or more contributor
  license agreements. See the NOTICE file distributed with this work for additional
  information regarding copyright ownership. The ASF licenses this file to
  You under the Apache License, Version 2.0 (the "License"); you may not use
  this file except in compliance with the License. You may obtain a copy of
  the License at http://www.apache.org/licenses/LICENSE-2.0 Unless required
  by applicable law or agreed to in writing, software distributed under the
  License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS
  OF ANY KIND, either express or implied. See the License for the specific
  language governing permissions and limitations under the License. -->
<document>
  <properties>
    <title>Commons Codec - User guide</title>
    <author email="dev@commons.apache.org">Commons Documentation Team</author>
  </properties>
  <body>
    <!-- ================================================== -->
    <section name="User guide">
      <p> Codec is comprised of a set of utilities and a simple
        framework for encoding and decoding text and binary data.
      </p>
      <subsection name="Binary Encoders">
        <p>Interfaces and classes used by the various implementations in
          the sub-packages.
        </p>
        <table>
          <tr>
            <td width="150">
              <a href="apidocs/org/apache/commons/codec/binary/Base32.html">Base32
              </a>
            </td>
            <td>
              Provides Base32 encoding and decoding as defined by
              <a href="http://www.ietf.org/rfc/rfc4648.txt">RFC 4648</a>
            </td>
          </tr>
          <tr>
            <td width="150">
              <a
                href="apidocs/org/apache/commons/codec/binary/Base32InputStream.html">Base32InputStream
              </a>
            </td>
            <td>Provides Base32 encoding and decoding in a streaming
              fashion (unlimited size).
            </td>
          </tr>
          <tr>
            <td width="150">
              <a href="apidocs/org/apache/commons/codec/binary/Base64.html"> Base64
              </a>
            </td>
            <td>
              Provides Base64 encoding and decoding as defined by
              <a href="http://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
            </td>
          </tr>
          <tr>
            <td width="150">
              <a
                href="apidocs/org/apache/commons/codec/binary/Base64InputStream.html">Base64InputStream
              </a>
            </td>
            <td>Provides Base64 encoding and decoding in a streaming
              fashion (unlimited size).
            </td>
          </tr>
          <tr>
            <td width="150">
              <a
                href="apidocs/org/apache/commons/codec/binary/BinaryCodec.html"> BinaryCodec
              </a>
            </td>
            <td>Converts between byte arrays and strings of "0"s and
              "1"s.
            </td>
          </tr>
          <tr>
            <td>
              <a href="apidocs/org/apache/commons/codec/binary/Hex.html"> Hex
              </a>
            </td>
            <td>Converts hexadecimal Strings.
            </td>
          </tr>
        </table>
      </subsection>
      <subsection name="Digest Encoders">
        <table>
          <tr>
            <td width="150">
              <a
                href="apidocs/org/apache/commons/codec/digest/DigestUtils.html">DigestUtils
              </a>
            </td>
            <td>
              Simplifies common
              <a
                href="http://download.oracle.com/javase/6/docs/api/java/security/MessageDigest.html">MessageDigest</a>
              tasks and provides GNU libc crypt(3) compatible password hashing functions.
            </td>
          </tr>
        </table>
      </subsection>
      <subsection name="Language Encoders">
        <table>
          <tr>
            <td width="150">
              <a
                href="apidocs/org/apache/commons/codec/language/Caverphone1.html">Caverphone 1.0
              </a>
            </td>
            <td>Encodes a string into a Caverphone 1.0 value.
            </td>
          </tr>
          <tr>
            <td width="150">
              <a
                href="apidocs/org/apache/commons/codec/language/Caverphone2.html">Caverphone 2.0
              </a>
            </td>
            <td>Encodes a string into a Caverphone 2.0 value.
            </td>
          </tr>
          <tr>
            <td width="150">
              <a
                href="apidocs/org/apache/commons/codec/language/ColognePhonetic.html">Cologne Phonetic
              </a>
            </td>
            <td>Encodes a string into a Cologne Phonetic value.
            </td>
          </tr>
          <tr>
            <td>
              <a
                href="apidocs/org/apache/commons/codec/language/DoubleMetaphone.html">Double Metaphone
              </a>
            </td>
            <td>Encodes a string into a double metaphone value.
            </td>
          </tr>
          <tr>
            <td>
              <a
                href="apidocs/org/apache/commons/codec/language/Metaphone.html">Metaphone
              </a>
            </td>
            <td>Encodes a string into a Metaphone value.
            </td>
          </tr>
          <tr>
            <td>
              <a
                href="apidocs/org/apache/commons/codec/language/RefinedSoundex.html">Refined Soundex
              </a>
            </td>
            <td>Encodes a string into a Refined Soundex value.
            </td>
          </tr>
          <tr>
            <td width="150">
              <a
                href="apidocs/org/apache/commons/codec/language/Soundex.html">Soundex
              </a>
            </td>
            <td>Encodes a string into a Soundex value.
            </td>
          </tr>
        </table>
      </subsection>
      <subsection name="Network Encoders">
        <table>
          <tr>
            <td width="150">
              <a href="apidocs/org/apache/commons/codec/net/BCodec.html"> BCodec
              </a>
            </td>
            <td>
              Identical to the Base64 encoding defined by
              <a href="http://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a>
              and allows a character set to be specified.
            </td>
          </tr>
          <tr>
            <td width="150">
              <a href="apidocs/org/apache/commons/codec/net/QCodec.html"> QCodec
              </a>
            </td>
            <td>
              Similar to the Quoted-Printable content-transfer-encoding
              defined in
              <a href="http://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a>
              and designed to allow text containing mostly ASCII
              characters to be decipherable on an ASCII terminal without
              decoding.
            </td>
          </tr>
          <tr>
            <td width="150">
              <a
                href="apidocs/org/apache/commons/codec/net/QuotedPrintableCodec.html"> QuotedPrintableCodec
              </a>
            </td>
            <td>
              Codec for the Quoted-Printable section of
              <a href="http://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a>
              .
            </td>
          </tr>
          <tr>
            <td width="150">
              <a href="apidocs/org/apache/commons/codec/net/URLCodec.html"> URLCodec
              </a>
            </td>
            <td>
              Implements the
              <code>www-form-urlencoded</code>
              encoding scheme, also misleadingly known as URL encoding.
            </td>
          </tr>
        </table>
      </subsection>
    </section>
    <!-- ================================================== -->
  </body>
</document>